Draft Website without Pencil again, very persistent


#1

I have a draft, but I do not have the pencil again

I deleted all Storage data from the skysails page via the chrome IDE
that caused me to no longer be logged in on anymod.com too.

PS: Intercom seems to still leave data inside LocalStorage? !

Afterwads I had to go to anymod page and I needed to re-Sign-in via Google again .

this method is the only One I know of to solve the given problem. It comes up daily , again and again, at the moment.

https://anymod.com/projects/8P24PE/dashboard


#2

some 20 minutes LAter I am faced with the very same issue again. I was logged in as admin and the clicked the draft link (comming from the admin draft interface). I clicked one of the mods and started to look at the drafted version. I feld quiet a high amount of mods did not change at all, but where assigned to have some changes inside. Today I was too stressed , so I ignored all of the problems at hand, I simply pushed all changes live. Afterwards the pencil was gone. I was unable to leave the draft version again. Also was I unable to edit the draft-version of cause. AND it did NOT solve my problem to merely call the anymod interface (stilll logged in as admin there) and log out ther , and log back in there, and then try to load the skysails page again = Nothing changed . I am still in draft mode and remain unable to leave the draft mode


#3

I had to clear all storage on skysails again.

then log back into anymod.com again

then reload the skysails page again

afterwards I was on admin at the skysails.page


#4

Thanks for the additional information. Is this behaving differently than your other issue? We are working on that one, so I want to make sure this is not something else.


#5

There might be a lot of similarity between both occasions, but maybe this ticket contains some additional information, missing inside of the other ticket, I cannot say. They seem related, that much is for sure. And the issue is replicable. I cannot not compare both ticket-information against one another in detail .


#6

This is what we’ve tried:

  1. Log into Anymod
  2. Visit one of your draft links
  3. Navigate around the site
  4. Visit another draft link
  5. Navigate around the site some more

We haven’t been able to get the pencil to not show up. If there is a set of steps you’re following that makes it not show, please let us know so we can try to replicate the bug.


Issues with the draft version
#7

#8

this ticket talks about the same issue , Issues with the draft version, but let us go on chatting inside of this chat


#9

ps: I have several tabs open with the customers Page open inside of those tabs. I guess that will not affect the changes anymod performs in my browser after the draft-link got clicked? As clicking any link on the Draft-URL in the admin panel will always open a new TAB with the customers STARTpage open , I assume the drafted-Version will only relate to that single tab. But I might be mistaken, did not yet look into that by testing this


#10

pps: Closing the browser entirely and starting the chrome app again will also not bring the pencil back , also it is irrelevant if I am logged in to anymod as an admin or not - once the pencil has vanished I am forced to delete all chached data in order to be able to LEAVE the draft mode (as I SUPPOSE I might still be in draft mode) eventually at that time


#11

THANK YOU for the video – it was really helpful! It looks like you’re clicking on the “view mod” links, which are designed to be view only, so that’s why the pencil isn’t showing.

Clicking on the actual draft link will cause the pencil to show (for your editors), while clicking on “view mod” only does viewing.

We now realize that this behavior is (obviously) pretty confusing, so we will incorporate your feedback into the redesign.

Please let me know if you’re still having issues!


#12

I created another video but I lost it after it was created, too bad. Well, I will not do it again.

I found out the following :


#13

I found out the draft link did also not trigger the pencil.

The pencil does not show up on either link .

That was the reason I tried to create a second video - at the end of that non successful second video-production, I found out there is one button on the draft-url-site indeed creating the pencil, and that is the button at the top right


#14

Hi Stefan, this is indeed the intended functionality: the “view” links don’t show the pencil because they are not meant to be used for edits (only for reviews). Sorry it is so confusing! We are rethinking this entire flow.


#15

okay, thanks for feedback :wink: