Publish Draft does not work at all


#1

I happend to have worked on a DRAFT.

I was NOT even aware I was working on a draft.

After I realized my mistake, I tried to publish my changes LIVE.

That did not work.

Please support:

I remained unable to publish

https://anymod.com/projects/824PN4/drafts/792682d6rn


#2

Hi Stefan, we’re not able to see the page since it’s password protected. Can you message me with the details of how to view the page?


#3

Hi Tyler, regretfully, this time, I cannot provide you with the credentials.
Sorry.
As a workaround I will copy the new draft content and Paste it into the admin interface manually.

And as soon as the new Draft-interface will be online, I will probably be able to delete the entire Draft myself.
I will use this as a workaround against the inability to publish the draft content live.

And I will delete the draft once the new draft interface is available.


#5

OK that sounds good. If you encounter the problem somewhere we can view it, we will be happy to take a look and see what we can fix. Thank you for reporting!


#6

Feedback: I can see the updated version if I look into the anymod interface for this mod here:

Thus: I found out the Mod did actually accept the PUBLISH-DRAFT-LIVE -Button I was hitting some days ago in vain.

The Mod in fact IS updated. At least inside the anymod-admin-interface.

BUT if I look at the webpage, then I can only see an OLD VERSION .

I killed all localStorage and Cookies and everything and I made 100% sure I am not on any Draft-View -VERSION.

I was not. Still the Mod online is OLD while the Mod inside the Anymod-Admin-Interface in fact is NEW.

I found out my HTML Page still had the V2 Script tag in the bottom of the body tag, so I moved it to the head-tag.

That did not solve the issue regretfully.

I thought I better provide you with another update.

Any Idea why?

Regretfully I can still not grant you access to that page.

But as I was unable to apply the workaround as initially planned , I had to contact you once again .

I tried to manually migrate the content from the draft to the admin. But found out the ADMIN already HAS the NEW version. BUT it does not display when the page is requested LIVE.

Also the draft -site tells me the draft is NOT live. Strange

At the same time I can say that hitting the Publish button does not work. And the publish draft button also does not change color if it gets hit. Nothing happens .

I am…

Well I hope you might be able to make sense of it all and fix it


#7

Hi Stefan, this sounds a lot like a cache issue. If the mod is updated for you in the editor, then your website is probably still receiving an older version because it is cached.

Can you try this:

  • Go to the project’s Pages section
  • Find the page in question
  • Expand it and click “Clear cache”

Let me know if that doesn’t work!


#8

Done. That was a bit of a hassle. Thank you for your quick reply Tyler.