Localhost cache

The localhost chache will no longer update after I deleted a mod-field.

The localhost chache is too persistent.

Today, I think I might have been able to identify ONE scenario where the localhost chache will no longer update. And I do not mean for some 3 Minutes, I mean the chache will no longer update for many future Month’s to come:

Whenever I delete a FIELD , the entire page will be delivered from AnyMods Localhost cache, withoout updating the CONTENT to the latest version anymore.

The old cached version of that Page will be delivered to my localhost (as soon as I deleted a mod-field inside of any Mod displayed on that html-page ).

It will then become mandatory for me to go to the link below (PAGES section on anymod admin Panel) and delete the chache for that page each time after I deleted a mod-Field

Only localhost seems to be affected!

Today this happened to me on 5 html-Pages. At least, now I know why and when this might happen. It leads to the localhost pages becomming non responsive to any content changes, also the SAVE AND PUBLISH Button will never grey out. The content in FACT IS STORED, but the button does not grey out, wrongfully indicating the data was actually not stored. This is pretty disturbing

can you confirm this, or am I mistaken? Not sure. This is just a “solid guess” :wink:

I deleted the field “headlineH2” in the field section.

I switched to the content Section afterwards.

That field still showed up there in the content-section.

Had to wait a while and refresh this page 5 times before the changes where visible in the content-section

I started this ticket some 1 hour ago.

Not only am I still fighting with those cache issues, additionally I cannot clone the mod I aim to clone .
I will try to clone a different mod, to see if the issue occurres for more than just that one mod

okay, it seems the MOD WAS cloned, although the cloning was NOT CONFIRMED. Instead I frequently saw that Modal comming up . It contained the information that there was a “Problem creating mod”

The sync process is affected also. And Also The Live page has the same issues regarding the cahche , just as the localhost.
All this slows down my working speed considerably today

While Cloning Mods I always get the message: “Problem creating mod”.

Sometimes the new mod IS cloned successfully.

Sometimes it is not cloned successfully.

My last attempts all where without success.

Working is almost impossible with anymod today.

also: I am back to hitting F5 each time after I saved any change to any mod . The anymod -brower-refresh function no longer works.

Hi Stefan, we are very sorry for this issue!

We exceeded our plan limits for one of our service providers, and rather than give us a warning, the service simply stopped accepting updates. That is why you were not able to see updates or to clone mods, and it’s why the cache was not being updated as well.

We’ve fixed the issue, and the service is now on an auto-scaling plan. Very sorry that it caused you to waste time! Please let us know if you are still experiencing issues.

Thank you Tyler,

Okay, understood. So I assume the issues are solved now. In case I run into those issues again, I will drop you another short notice

Hi Tyler,

I am running against the same Cache-related issues today.

The above description fully applies.

OK we are looking into it now. Which project is it? We will clear the cache manually in the meantime.


We’ve cleared all the cache manually, and also pushed a change that should prevent this from happening. This is an error coming from one of our service providers, so we are handling those errors now rather than having them “break” the request. Please let us know if you continue to experience this, and again we are sorry for the problems!

OK, will provide an update

1 Like